BonnevilleAmerica.com | Forums Home | Photopost Archive | Disclaimer

Technical Forums >> Accessories

Pages: 1
1000YOMan
Complete Newb


Reged: 09/17/19
Posts: 1
Loc: Forest Hill MD
Tachometer not working
      #679138 - 09/17/19 12:03 PM

I have 2008 America. It has a Triumph tach mounted in the console. It stopped working. I got an a/m replacement from Fast Eddie. It's a Drag Specialties tach. It's the same size to fit in the console. Problem: I want to clip the connector off the non-functional original tach and splice it to the replacement unit. I just don't know which wires get spliced to each other. Has anyone done this and if so can you help me out? TIA

Post Extras: Print Post   Remind Me!   Notify Moderator  
The_Dog33
Fe Butt


Reged: 02/01/07
Posts: 22527
Loc: NE PA USA
Re: Tachometer not working [Re: 1000YOMan]
      #679290 - 09/30/19 05:50 PM

Easy enough to look at the wiring diagram for the stock tach, the Drag Specialties tach should have instructions telling you what wire is what.

--------------------
I learned all I need to know about life by killing smart people and eating their brains.
Eat right ,Exercise ,Stay fit, Die Anyway!
some shots of our bikes


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 23 anonymous users are browsing this forum.

Moderator:  moe, Dinqua, freedom 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 436

Rate this topic

Jump to

Contact Us | Privacy statement BonnevilleAmerica.com Homepage

Powered by UBB.threads™ 6.5.5